>

Apple release Front Row 2.1.6 with bug fixes

Apple has finally released Front Row 2.1.6, a download which brings improved iTunes 8.0 compatibility along with fixing a few much needing fixing bugs.

For the user to use Front Row 2.1.6 they will obviously require a Macintosh computer enabled with Mac OS X v10.5 or even later, iTunes 6.0.4 along with iPhoto 6.0.2 or even later, and Quicktime 7.5.5 or later.

Want it? You can download the software update and a stand alone installer from here. Oh by the way, if you happen to come across anything wrong with Apple’s Front Row 2.1.6, we’d be happy to hear about it

Front Row 2.1.6 is available via Software Update and also as a standalone installer.

Source macdailynews.