iOS 5.1 concerns and implications on jailbreaking

It’s only been a couple of days now since Apple announced the availability of the latest operating system for their mobile devices. There are many users of the platform who prefer to jailbreak their iOS device, but with this latest version of the software there are concerns and implications on jailbreaking iOS 5.1.

There have been many reports in the past where users have mistakenly lost their precious jailbreak, and it was believed it was just the simple case of returning to an earlier firmware version only to discover it couldn’t be done. Today we can tell you that an article on iDownloadBlog is reporting that the iPhone Dev Team are warning users about the iOS 5.1 firmware.

The team that are behind jailbreaking tools such as RedSn0w among others has gone into detail about how each device is affected by the availability of iOS 5.1, and have basically warned not to update your hardware if you like to jailbreak it.

Users who have older hardware such as the first iPad, iPod Touch, and the iPhone 4 can still jailbreak them using the latest version of RedSn0w, but you will lose your untethered status though. Owners of the iPhone 4S meanwhile that upgrade to iOS 5.1 will find it impossible to either jailbreak it or to downgrade to an earlier version.

For users of the iPad 2 it is still possible to go back to a version of iOS 4, but only if you have 4.x blobs saved, which will supposedly allow you to jailbreak iOS 4.3.3 using JailbreakMe, but there is no chance of returning to either iOS 5.0 or 5.0.1, whether you have your blobs saved for those or not.

If you need more information it is suggested that you read the blog post from the Dev Team. Have you refrained from upgrading to iOS 5.1?

Live Comment

Your email address will not be published.