Android 4.2 Jelly Bean Nexus 7 update problems discussed

The Google Nexus 7 has become one of the most popular seven inch tablets since it was first released, and last week to coincide with all the new Nexus hardware becoming available Google starting rolling out the Android 4.2 Jelly Bean update to the older Nexus devices. Trouble is there have been numerous problems discussed by owners of the Nexus 7 since updating the firmware.

It seems that a growing number of Nexus 7 owners are experiencing a variety of issues after updating their device to the Android 4.2 Jelly Bean firmware, with the main issue being a flaky Bluetooth connection. That not to say there aren’t other problems with the new software, as we have been told by some of our readers that they have experienced the device suddenly rebooting itself unexpectedly.

There have also been complaints of faster battery drain in some cases along with a sudden lag with the Nexus 7 that wasn’t present before the update. This is slightly similar to what was experienced by owners of the Samsung Galaxy Nexus previously when their handset kept rebooting itself without warning, and many will remember the volume bug that caused the device to suddenly go silent during a call.

It’s a shame that the tablet PC is currently experiencing these issues as hardware wise it’s a great device, and some owners have seen the problems with updating to Android 4.2 but are holding off for now. The only trouble is that they have to put up with constant prompts about updating to the new firmware, but that’s better than having a device riddled with bugs.

Some users though are saying they are having no issues with their device at all after updating, so the problems may be related to certain apps installed on the tablet conflicting with the operating system. Hopefully Google will quickly address the issue and release a patch for the device and clear all the bugs.

Have you held off updating to Android 4.2 until Google irons out all the problems?


61 thoughts on “Android 4.2 Jelly Bean Nexus 7 update problems discussed”

  1. Twitch says:

    Could be some apps if it were my guess. My girlfriend has an HTC EVO 4G LTE and was experiencing a ton of issues with the device. It would shut off and not come back on…randomly, maybe the first day she had it maybe the 3rd week. She went through about 4 swaps (which were all brand new, due to the time frames this was happening in)every single one had the same issue. Turns out it was a game called SongPop! Google play had multiple owners of different devices with issues. Hasnt downloaded that game since and has since had no issues.

  2. Laura says:

    I updated to 4.2 last week and found that I could no longer tether to my iphone, the screen filter app that I use all the time doesn’t work and I hated the appearance of the clock. I backed up and went back to 4.1.2. I tether regularly so I can’t afford to hang around waiting for the bug to be fixed. Now just looking for a way to stop the annoying update prompts!

  3. I’ve always done a factory reset of every device and had my devices plugged in and fully charged when I’ve updated them all and never ran into any issues that others seem to have with each device. I suggest doing the same when updating software for a worry free update. – KID ANDROID. ( Team.Android.Canada).

  4. Inciter says:

    I did not update manually but i did force the OTA by clearing my system cache. The update so far has been bug free (bluetooth not used); I have one gripe and that is with Google news. The side stories in Google news will zip back to the left when I pinch for larger screen viewing. Is anyone seeing this as well? That would be on my N7 16.

    I know eggheads like me did a DL of the apk and I was thinking of doing that’ but I found a nice text that was much easier to force the update from OTA. Let’s call it a clean Update as some had to work the update by more manipulation. I also wonder if the ones with rooted systems are seeing the bugs more than anyone else?

    I know a large number use the n7 as rooted systems and different ROMS; are these the folks truthfully saying that thay have bugs and are rooted? Or the clean install users?

  5. Warren Buddin says:

    I have no problems on my nexus 7 or galaxy nexus running stock 4.2. I would say it is app related, in which case it is up to the developers of those apps to fix, not Google. Or the user can troubleshoot and remove the problem app. If the app hasn’t been updated in a long period, it’s safe to say the developer hasn’t made it 4.2 ready.

  6. Brad says:

    has rebooted twice on me while in the middle of a texas holdem tournament in Zynga poker, i am afraid to keep playing as I don’t want to lose my money. Locks up Hero’s Call often. The default widget that displays recommended apps quit working. Other apps are glitchy. Wish I wouldn’t have upgraded. (Blue tooth is off, btw..)

  7. Joshua Lieder says:

    I updated to 4.2 and my Nexus is buggy now with a weird half formed box on the main screen, an odd clock with only half bold numbers on it, and many of the apps take forever to open and require multiple attempts. Its really not an improvement that I can see. Where do I complain officially please? Thanks.

    1. Mary Riedel says:

      This is what I have noticed: a half box on the left at the password splash screen, multiple splash screens if I go forward or backward, one different, two the same (three in total) and a very unattractive font for the time that looks different for the hour than it does for the minutes. So far I’m ignoring it as I suspect it will eventually become corrected or work itself out (I figure we don’t all need to phone them and that plenty probably already have). If not corrected soon, I’ll phone Google customer service – which is where it should be reported: 855-836-3987.

      1. Ryan says:

        The fix I found for this was to download an app called lockscreen Policy, click authorize, then toggle the lockscreen widget off, and finally longpress the clock and remove it completely. When you go out and then back in, the clock remains, but the flashing box is gone and everything works better. This will get you through until the fix from google, which will add corrrectly working locksceen widgets.

        1. Mary Riedel says:

          I followed your instructions. When I removed the digital clock another one popped up, so I removed that one also. I was left with a box with a plus (+) sign in it. I clicked off, then back on, entered by password, and the funky digital clock and the partial box on the left were both back.

  8. Gav456 says:

    Not necessarily a bug, but certainly a problem with the OS to do with user accounts. There’s no way to share files/media between users, like a public area. Also, I’d want a way (for at the least “user0” aka “tablet owner”) to view/delete other user’s content. What good is this ‘family tablet sharing’ idea if parents can’t monitor their kids usage? I want user0 to have administrative privileges. What if kids fill my memory with crap that I can’t delete without removing the user? Google needs to rethink this. We don’t have to download apps twice (just to activate on different user’s accounts) so there’s obviously some form of common area, we just can’t access it and use it to share media – suxx

  9. mike says:

    I am experiencing faster battery drain, WiFi drops, lags, and some apps crashing randomly, Google needs to address the WiFi and battery issues at once. I am on a nexus 7, which was fine before the 4.2 ota upgrade.

  10. Jigsy says:

    Mine has started to run very slow since the update. Everything lags including apps and games. But even the keyboard and the screen are reacting very slow with animations and keypresses

  11. Android Analyse says:

    Mine is now quite sluggish especially when switching between users (I have 4 users one mine) but the main concern is the noticeable battery drain. It used to go a few days before needing to be charged, now it’s daily.

    I’m not sure if this has anything to do with having multiple user accounts and potentially more background tasks running (if they are indeed running in the background of the accounts not currently being used) but in any event I’m considering going back to the previous version.

  12. clinton says:

    Since the update my outlook connection failed to connect due to ‘security issues’ – I get asked for a security certificate that cannot be found and our IT dept say the exchange server settings are correct. Outlook worked great before this damn upgrade – getting hacked off and eyeing the trash can and thinking of an i phone.

  13. Michael Smithson says:

    Mine won’t even update to 4.2 keeps getting so far then it stops and he little android dude is dead on his back with an exclamation mark over him.

      1. InkyMike says:

        Well since I posted my last comment i found out it was clockwork mod that was causing the issue. I removed it and the update went straight through.

  14. g-girl says:

    I had planned on buying one but then the new update came out and now I’m afraid too. I don’t want problems just an easy device to use. Now I wont be getting anything. 🙁

    1. Andy says:

      I think you should still get it, if you are still interested. Issues are inevitable. Eventually, they will put out an update to resolve all the issues. From experience, the Nexus 7 is an awesome device with a great price. I think you`ll enjoy it. Good luck!

  15. Dave Taylor says:

    Got mine last week went for the update then it would not work at all so I took it back and got a new one which did the same thing. I managed to restore it {factory setting} but it still keeps saying there is this update. I don’t know what to do I just keep saying NO

  16. mmmmattd says:

    I originally just had the screen brightness problem, now in the past day or two have seen a half dozen reboots, volume issues, the wifi thing and some wacky auto-rotate when it’s just laying flat on the desk. Funny part is that before 4.2, I had a few weeks of no problems once the previous update fixed the low space lag problem. C’mon Google!

  17. person says:

    I have been locked out of my Nexus7 ever since upgrade. It does not recognise my old password and an annoying android icon asks me to type password to decrypt storage?
    Very unhappy!

  18. Carl says:

    New N7 32gb crashes with flickering lines then reboots. Last time when it rebooted the google name came up with little blue dots around it. I couldn’t even get it to reboot. also making funny noise with the vol button turned off. Luckliy I’m within the 14 day return period. Will not be buying this product again until all the bugs are worked out.

  19. Kerry says:

    I updated yesterday. This afternoon it switched off by itself and now won’t switch on at all! Not happy as I use it for work. Any suggestions as to how to get it back on??

  20. hamboy says:

    My battery stats don’t update, they stay at 100% until the battery dies. There is nothing more annoying than playing a game or watching a video with no idea when the battery is suddenly going to die. Unless Google fix this soon, I will never be buying another Nexus device.

  21. wewe says:

    bought a nexus 7 for Christmas for my daughter and she updated the OS and hos not started since. It shows the X and don’t do anything.,…what can i do?

  22. David says:

    just got a brand new nexus 7. The device says the signal is good but I continually have the notice that the connection has timed out, and it won’t download. Sad to say, but a waste of money until this problem is fixed.

  23. Bart says:

    My tilt sensor doesn’t work any more (it did work for 1 day after the update to 4.2.1, but then failed, a reboot fixed it once, but now everything I’ve tried doesn’t).
    Also the screen brightness keeps changing out of sync with the room lighting, so I’ve had to switch the auto brightness control off.
    Very frustrating, I’m nearly at the point of taking it back and using my money for something else!

  24. MARC says:

    A number of us in the same office have the issue with both our Nexu 7’s and galaxy nexus phones after the 4.1.2 update. With the phones it seems to happen after losing signal in the basement and connecting to wifi all devices go in to a reboot loop. This also happens with our tablets which are wifi only so I think the issue is with the wifi, we changed routers for a newer model but had the same issue. We have done factory resets but the issue still persists even with just the stock apps so no alledged bad apps are installed. GOOGLE FIX THIS NOW!!!!

Live Comment

Your email address will not be published.